浜松のWEBシステム開発・スマートフォンアプリ開発・RTK-GNSS関連の開発はお任せください
株式会社シーポイントラボ
TEL:053-543-9889
営業時間:9:00~18:00(月〜金)
住所:静岡県浜松市中区富塚町1933-1 佐鳴湖パークタウンサウス2F

【Node】ライブラリインストール時に「The engine “node” is incompatible with this module」エラーが発生した時の対処法

ちょっとハマりかけたので備忘録としてまとめ。

エラー全文はこちら

@typescript-eslint/parser@3.8.0: The engine “node” is incompatible with this module. Expected version “^10.12.0 || >=12.0.0”. Got “11.13.0”

エラーメッセージに @typescript-eslint/parser というライブラリ名が入っていたので、こちらのバージョンに問題が?と思ったのですが、正しくは、現在の Node.js のバージョンと互換性がないことが原因でした。

参考にさせていただいた記事はこちらです。

yarn installで”The engine “node” is incompatible with this module”というエラーが発生した件 – Qiita
https://qiita.com/taraontara/items/4af9ed38dbe305d35ee9

 

対処方法としては、Node.js のバージョンをエラーメッセージが推奨しているバージョンにアップグレードすればOKでした。
私の場合、10.12.0 または 12.0.0 以上にしなさいとのことでしたので、12.0.0 に更新しました。
なお、現在のバージョンは 11.13.0 だったようです。

Node.js のバージョン更新については、私の環境では Nodist を使って管理していたので、下記のコマンドを実行して更新しました。

nodist + 12.0.0  // 12.0.0 の Node.js をインストール
nodist 12.0.0  // 使用する Node.js のバージョンを指定

あとは node -v を実行して、バージョンが 12.0.0 になっていれば更新完了です!

その後、再度ライブラリをインストールするコマンドを実行したところ、問題なくインストールが完了しました。

 

以上、ライブラリをインストール時に、「The engine “node” is incompatible with this module」エラーが発生した時の対処方法についてでした。
ご参考になれば幸いです。

  • この記事いいね! (1)