【Cordova】「The versions of the Android Gradle plugin and Gradle are not compatible.」エラーの対処法

村上 著者:村上

【Cordova】「The versions of the Android Gradle plugin and Gradle are not compatible.」エラーの対処法

ちょっとミスをして、Cordova アプリから Android プラットフォームの削除・再追加を行ったのですが、その時に発生したエラーについて。
Android Studio のバージョンを上げたのも原因だったのかも?

Gradle のバージョンに関するエラーで、全文は下記のとおり。

ERROR: The versions of the Android Gradle plugin and Gradle are not compatible.
Please do one of the following:
Update your plugin to version 2.4. This will require changes to build.gradle due to API changes.

エラー:Android GradleプラグインとGradleのバージョンは互換性がありません。次のいずれかを行ってください。プラグインをバージョン 2.4 に更新してください。これはAPIの変更により build.gradle への変更を必要とします。」とのこと。

 

そのため、エラー文に書いてある通り、build.gradle のバージョンを更新しました。
また、Android Studio の File > Project Structure の Project でも、バージョンを確認しました。
…が、最初はどこを直していいのかわからず、いろんなところを直しては戻し、また別のところの値を変え…とやっていたら、いつのまにか直っていた感じなので、確認箇所がこれでいいのかは不明です。

一応、参考にさせていただいたサイトを挙げておきます。

[Android Studio][gradle]gradleとAndroid plugin for gradleのバージョンを合わせる
https://qiita.com/azumak/items/c48c56447a7a345f2b43

 

以上、Android Studio で Gradle のバージョンエラーが発生した際の対処法についてでした。
あまり参考にならない気もしますが…。

  • この記事いいね! (0)

著者について

村上

村上 administrator