浜松のWEBシステム開発・スマートフォンアプリ開発・RTK-GNSS関連の開発はお任せください
株式会社シーポイントラボ
TEL:053-543-9889
営業時間:9:00~18:00(月〜金)
住所:静岡県浜松市中区富塚町1933-1 佐鳴湖パークタウンサウス2F

【Android】「Could not find com.android.support:appcompat-v7:27.0.2.」エラー

数年前の Android アプリを起動した際に遭遇したエラーについてです。
諸事情あって、ビルドできるかどうか実行してみたところ、Sync Project With Gradle Files を実行した時点で早速躓きました…。
遭遇したエラーは「Could not find com.android.support:appcompat-v7:27.0.2.」です。

こちらの対処方法ですが、検索したところ下記の記事がヒットしました。

Failed to resolve: com.android.support:cardview-v7:26.0.0 android – Stack Overflow
https://stackoverflow.com/questions/45103230/failed-to-resolve-com-android-supportcardview-v726-0-0-android

 

上記の記事によると、build.gradle ファイルに maven { url "https://maven.google.com" } を追加すればよいとのことでした。
具体的なサンプルコードは下記のとおりです。

allprojects {
    repositories {
        jcenter()
        maven {
            url "https://maven.google.com"
        }
    }
}

4~6行目を追加しました。
こちらを追加後、再度 Sync Project With Gradle Files を実行したところ、無事「Could not find…」というエラーは表示されなくなりました!
その代わりに別のエラーが発生しているので、まだビルドできる段階にすら至れていませんが…こちらについても、これから対応していきます。

 

以上、Android プロジェクトで「Could not find com.android.support:appcompat-v7:27.0.2.」エラーが発生した時の対処方法についてでした。
ご参考になれば幸いです。

  • この記事いいね! (0)