【react-native】cocoapodsの読み込みに失敗した時に試したこと

※今回は自分用です。

react-native run-iosでビルドしようとしたところ

Installing CocoaPods dependencies (this may take a few minutes)
:×: Installing CocoaPods dependencies (this may take a few minutes)
error Error: Failed to install CocoaPods dependencies for iOS project, which is required by this template

というエラーに遭遇。

cocoapodsが適切にインストールできていなかったのが原因みたいです。

実際にはcocoapodsはインストールされていたのですが、githubに登録した

プロジェクトファイルではなくリモートリポジトリ

から取ってきたプロジェクトファイルを使って開発していたので

そのファイルにはcocoapodsは適用されていないということでした。

ここは、以下のようにcocoapodsをアンインストール→再度インストールする。

①xcodeを開く

②Preferencesを開く

③Location Tabを開く

④xcodeのバージョンを指定する

⑤sudo gem uninstall cocoapods(cocoapodsをアンインストール)

⑥sudo gem install xcodeproj(xcodeprojをインストール)

⑦sudo gem install cocoapods(cocoapodsを再度インストール)

 

これで無事ビルドが通りました。

>株式会社シーポイントラボ

株式会社シーポイントラボ

TEL:053-543-9889
営業時間:9:00~18:00(月〜金)
住所:〒432-8003
   静岡県浜松市中央区和地山3-1-7
   浜松イノベーションキューブ 315
※ご来社の際はインターホンで「316」をお呼びください

CTR IMG