【create-react】npmのバージョンが古い状態でwebpackをインストールするとエラーが起きて読み込み終了する

asaba 著者:asaba

【create-react】npmのバージョンが古い状態でwebpackをインストールするとエラーが起きて読み込み終了する

webpackを更新したくてnpm install –save-dev webpackで最新のwebpackをインストールすることに。

npm run webpackしたところで

 

Cannot read property ‘thisCompilation’ of undefined npm ERR! というエラー出現

 

原因はnpmのバージョンとインストールしたwebpackのバージョンのズレでした。

npmが古すぎるとwebpack読み込み時にエラーが起きて読み込み中断してしまう

みたいです。

 

 

解決方法は、一旦ダウンロードした新しいwebpackをnpm remove webpackで

 

アンインストール→その後バージョン@3.11.0をインストール。赤文字でERRと出なければ解決です!

同じことではまっている方は今使っているnpmのバージョンを確認してみてください。

  • この記事いいね! (0)

著者について

asaba

asaba author

好きなもの:RPG、チョコミント 少しずつ頑張ります。