【android】古いandroidStudioを消したらマニフェストが狂った

asaba 著者:asaba

【android】古いandroidStudioを消したらマニフェストが狂った

新しいandroidStudioに触れて早三か月となったある時、Cドライブが圧迫

し始めていることに気づいた。

 

要らないファイルを少しずつ消していたところ、もう使っていない

androidStudioのファイルを発見。

2.0と3.0だったのでもう使わないからいいやと思い軽い気持ちで削除。

ここまでは良かった。ところが翌日になって現行のandroidStudioを

立ち上げるとこんなエラーが起きていた。

 


<span style="color: #800000;"><strong>The minSdk version should not be declared in the android manifest file. You can move the version from the manifest to the defaultConfig in the build.gradle file</strong></span>

 

マニフェストにminSDKのバージョンを書くなとのこと。なん・・・だと・・・。

つい昨日までマニフェストに明記していたはずのminSDKが今のバージョンで

読み込めなくなっていた。

 

原因は消したandroidStudioファイルの中のキャッシュも一緒に

消したためだと思われる。

 

書いておいたminSDKのバージョンを消すと正常にビルドできた。

これ以降はandroidstudioを復元しなくても普通に動いてくれたので

このまま明記しなくても良さそう。

  • この記事いいね! (0)

著者について

asaba

asaba author

好きなもの:RPG、チョコミント 少しずつ頑張ります。