【node.js】node.jsのバージョンが8以下だとcreate-react-appが使えなくなりました

asaba 著者:asaba

【node.js】node.jsのバージョンが8以下だとcreate-react-appが使えなくなりました

react初級者が手っ取り早くreact開発をするのに便利だったcreate-react-appですが、知らない間にnodeの

バージョンが低いとcreate-react-appでテンプレートを作れなくなっていました。

今の自分のnodeのバージョンが6.3.10だったのですが、試しにcreate-react-app toyBoxで適当にテンプレを

作ろうと思って実行したところ、このようなエラーが出ました。


Y<span style="color: #ff6600;">ou are running Node 6.10.3.</span>
Create React App requires Node 8 or higher.</span>
Please update your version of Node.</span></span>

分かりやすい。このエラーが出た場合は今のnodeから8以上のnodeに切り替えてください。

nodistをインストールしている場合は、コマンドでnodist +8.0.0でnodeのバージョン(8以上なら何でもいい)を

インストールします。その後に同じくコマンドでnodist 6.11.3と打ち込んで現在のnodeから実際に8.0.0に

切り替えます。

node -vでバージョンを確認して8.0.0になっていれば切り替え成功です。ここで再度create-react-app toyBox

を打ち込んでみましょう。緑色の文字でsuccessが出れば成功になります。

もし、正常に動かないまたはnode.jsのバージョンが変わらなかった場合は一回node.jsをアンインストール

することをお勧めします。

 

  • この記事いいね! (0)

著者について

asaba

asaba author

好きなもの:RPG、チョコミント 少しずつ頑張ります。