【npm】phonegap-plugin-speech-recognationが読み込めない

asaba 著者:asaba

【npm】phonegap-plugin-speech-recognationが読み込めない

今回のネタはphonegap-plugin-speech-recognitionを使おうとしてReferenceError: SpeechRecognition is not definedで怒られたのと

その対処法についてです。

phonegap-plugin-speech-recognitionとは、入力された文字に対して、その文字を読み取って音声で返してくれるプラグインのことです。

プラグインの紹介をしたところで本題に入らせていただきます。

まず、あるアプリにphonegap-plugin-speech-recognitionを追加して動作確認をしたところReferenceError: SpeechRecognition is not

definedで行き止まりをくらいました。

ん~、インストールしたのにな・・・と思い渋々npm install phonegap-plugin-speech-recognitionをすると

下記の画像のようにエラーがずららっと表示されました。

 

ここで、試しにnpm lsコマンドでphonegap-plugin-speech-recognationが存在するか確認をしてみました。

するとなにやらにおうエラーを発見

npm ERR! missing: phonegap-plugin-speech-recognition@git+https://github.com/macdonst/SpeechRecognitionPlugin.gitとな・・・

missingのエラーなので、webpack関係ではないし、コルドバのバージョンを指摘されている訳ではない。だとしたら保存形式の関係?

という訳でpackage.jsonの中身を探索してみることに・・・

 

package.jsonの中身を見てみると、やはりバージョン形式ではなくurl形式で保存されていたので、これで読み込みができていないのでは

と思いpackage.jsonの中の“phonegap-plugin-speech-recognition”: “https://github.com/macdonst/SpeechRecognitionPlugin.git”,を

現行のバージョンである“phonegap-plugin-speech-recognition”: “0.3.0”,に変更

無事にプラグインも動作しました。npm のバージョンを変えたりしていなければこの保存形式で問題ないと思われます。

※githubのアカウントを作って公開鍵を登録しないと”https://github.com/macdonst/SpeechRecognitionPlugin.git”では読み込んでくれない

ことが判りました。gitとか登録していない人は上のようにバージョンを表記する形にしておいてください。

 

参考ー>https://ja.stackoverflow.com/questions/20541/vue-js%E3%81%AE%E6%97%A5%E6%9C%AC%E8%AA%9E%E3%83%89%E3%82%AD%E3%83%A5%E3%83%A1%E3%83%B3%E3%83%88%E3%82%92%E3%83%AD%E3%83%BC%E3%82%AB%E3%83%AB%E3%81%A7%E5%AE%9F%E8%A1%8C%E3%81%97%E3%82%88%E3%81%86%E3%81%A8%E3%81%99%E3%82%8B%E3%81%8C%E3%81%A7%E3%81%8D%E3%81%AA%E3%81%84

  • この記事いいね! (0)

著者について

asaba

asaba author

機種依存は悪い文明